康康

Gen8配合Proxmox虚拟爱快 + LEDE + 黑群辉组建千兆家庭网
前言这几天一直忙着孩子,都没空管博客了,而且昨天还断了网,不过还好,之前在奶茶那里订购的千兆五口交换机到货了,而且...
扫描右侧二维码阅读全文
16
2018/10

Gen8配合Proxmox虚拟爱快 + LEDE + 黑群辉组建千兆家庭网

前言

这几天一直忙着孩子,都没空管博客了,而且昨天还断了网,不过还好,之前在奶茶那里订购的千兆五口交换机到货了,而且网络也已经恢复,于是趁着孩子睡着了,赶紧把家庭网重新捣鼓了下,实现了简单的家庭千兆组网。

家里两条宽带,都是移动50MB免费那种,本次组网仅涉及其中一条网线,另一条专门提供给父母看网络电视的,所以无需组网。

配置方案

前期房子已经预埋了网线,不过是普通的网线,不过移动宽带也没超100M,所以也无所谓。

Gen8安装Proxmox,并开设虚拟机安装爱快、LEDE、黑群辉。

爱快作为主路由负责拨号上网,LEDE作为二级路由,负责广告过滤、无痛穿墙。

所有设备均通过交换机连接LEDE进行网络访问。

Gen8的网口1作为LAN使用,网口2作为WAN使用。

网络拓扑图

01.jpg

配置准备

  1. 一台带千兆网卡的PC(和交换机一起在某东订购的,四天了,依然在北京没挪窝),由于千兆网卡没到货,暂时使用主板自带百兆网卡;
  2. 一台千兆交换机;
  3. 一台WIFI路由或是AP设备(主要是解决手机等网络连接,没此需求可以PASS);
  4. 一台带有两个千兆网口的服务器(用于虚拟机安装软路由、黑群辉等);
  5. 超五类线若干。

其实还有其他的方案,比如在没有服务器的情况下,可以选择自己组装软路由硬件系统,一块集成CPU的主板+内存+1G硬盘+电源就搞定了,据说总价不超过200,不过康康因为有了Gen8,所以就没折腾那些。

目前康康的家用服务器是Gen8,配置进行了升级,目前搭配为:

CPU:Intel(R) Xeon(R) CPU E3-1230 V2 @ 3.30GHz
内存:8GB DIMM DDR3 1600Mhz x2
SSD:Inetl 545s 128G
硬盘:WD红盘 4TB SATA6Gb/s 64M WD40EFRX x 4

虚拟系统选择

支持虚拟机的程序很多,比如常见的ESXI、Hyper-V、VMWare等等,不过本次康康使用的是Proxmox,这是一款同时支持LXC(OpenVZ升级版)和KVM的虚拟机系统。

对于Gen8来说,网上很多教程都说的是搭配ESXI,因为有HP的定制版,又或者装Windows,在上面安装Hyper-V,其实这些都可以,但对于康康来说不是太理想。

原因嘛:

  1. Hyper-V属于Hyper架构的,对内存资源管控较为严格,换句话说,属于那种不容易超售的,这对于用户来说算是好事,但对于康康来说就不是了,因为俺不要求在虚拟机上开启的小鸡有多稳定啊,康康的服务器主要是用来做测试的,只要常用的几个小鸡稳定就行。而ESXI属于VMWare架构虚拟系统,理论上来说与LXC、OpenVZ类似,可以超售,但实际使用中,若超过了物理内存,则会造成母鸡的不稳定。
  2. ESXI和Hyper-V都是带有独立控制面板或控制软件的,但对于系统的安装,一般采用的是日常系统安装方式,即加载ISO,然后一路下一步走下去,当然也有相应的模板,但模板较少,系统安装不方便。
  3. Hyper-V是微软自家的虚拟机系统,属于有专门针对的虚拟系统,所以对于Windows的支持会非常友好,但对于其他系统的支持则相对伴有性能的损耗,而康康的测试环境又大多在Linux、Unix中。

所以呢,康康就选择了Proxmox,对于康康来说,Proxmox有这样几个优点:

  1. 同时支持LXC(OpenVZ升级版)及KVM,需要Linux环境直接LXC镜像安装,简单快捷,需要其他非Linux环境则使用KVM安装,同样支持控制台界面。
  2. Proxmox基于Debian系统,稳定性相比于Windows来说要高。
  3. 日常可能要添加多个虚拟机,会存在虚拟内存超过实际物理内存情况,使用LXC架构不容易引起太大问题。
  4. Windows下的Hyper-V由于是Windows下的程序,服务器首先得占用Windows的资源,然后又占用Hyper-V的资源,资源损耗高。
  5. Proxmox开源。

Proxmox安装

本次安装,康康将Gen8的硬盘模式修改为Archi模式,不使用Raid,并使用LVM合并四块HDD为一个分区使用,而系统则安装在SSD硬盘中。

基于此,康康并未选择直接安装Proxmox的ISO镜像,而是安装Debian 9.5,然后再安装Proxmox。

Debian的安装不多说,版本选择最新稳定版,要求为64位,分区的时候SSD单独组建一个LVM Group,并分配/rootswap/boot,四块HDD则组建为另一个Group,并分配单一的分区为/var/lib/vz,这是用来存放虚拟机的各种文件的,所以要足够大。

在Debian中安装Proxmox最新版,目前有个要求,就是必须设定hostname,并且IP必须指向特定的虚拟域名。

比如康康在安装Debian的时候,设置的主机名为usebsd,且IP地址要设置为192.168.1.3,那么,咱们在安装Proxmox之前,需要更改/etc/hosts文件,加入这样的一条记录:

192.168.1.3     usebsd.proxmox.com usebsd pvelocalhost

然后配置下网络/etc/network/interfaces

auto lo
iface lo inet loopback
iface lo inet6 loopback

auto eno1
iface eno1 inet static
    address 192.168.1.3
    netmask 255.255.255.0
    gateway 192.168.1.1

到这里已经可以进行Proxmox安装了,不过由于康康的网络是国内网络,而Proxmox的镜像源是在国外,速度实在是有够烂,所以咱们再更改下镜像源,这里康康选择了中科大的,对康康的网络最友好。

同时,为了避免国内DNS污染,选择https镜像模式,需要提前安装apt-transport-https,否则无法使用apt

apt install apt-transport-https

更换Debian镜像源:

echo -e "deb https://mirrors.ustc.edu.cn/debian stable main contrib non-free\ndeb https://mirrors.ustc.edu.cn/debian stable-updates main contrib non-free\ndeb https://mirrors.ustc.edu.cn/debian-security/ stable/updates main non-free contrib" > /etc/apt/sources.list

添加Proxmox中科大镜像源:

echo "deb https://mirrors.ustc.edu.cn/proxmox/debian/pve stretch pve-no-subscription" > /etc/apt/sources.list.d/pve-install-repo.list

下载公钥:

wget http://mirrors.ustc.edu.cn/proxmox/debian/proxmox-ve-release-5.x.gpg -O /etc/apt/trusted.gpg.d/proxmox-ve-release-5.x.gpg

执行Proxmox安装:

apt update && apt dist-upgrade
apt remove os-prober # 这一步不是必须的,但是官方推荐的
apt install proxmox-ve postfix open-iscsi

安装完成Proxmox后,原本Debian自带的Linux内核对于我们已经无用了,所以咱们可以删除Debian内核并更新引导:

apt remove linux-image-amd64 linux-image-4.9.0-*-amd64
update-grub

由于康康使用的是免费版本,是没有商业订阅的,所以商业源对于咱们没有任何作用,反而在更新时还会出现无法访问的错误,咱们删掉:

rm -f /etc/apt/sources.list.d/pve-enterprise.list

这样Proxmox就安装好了,现在可以通过https://192.168.1.3:8006登录Proxmox的Web管理界面,管理后台自带中文语言,选择下就行了。

02.jpg

系统运行情况。

03.jpg

到这一步,Proxmox算是已经成功运行了,不过还没完,咱们还得对网卡进行下配置,上面配置,只是为了能够方便联网,而且对于Proxmox的安装,也需要虚拟域名能够正确指向IP,所以刚才就设置了下,现在则要设置今后所使用的IP地址,点击咱们的节点,选择“系统” —— “网络”,可以看到当前的网卡信息。

04.jpg

双击任意一张网卡可打开网卡编辑界面。

05.jpg

咱们把所有信息清空并提交,仅保留自动启动选项。

06.jpg

创建一张桥接网卡,“创建” —— “Linux Bridge”。

07.jpg

名称一般就是vmbr(x),我这里为了方便区分,序号就和物理网卡一致,名称为vmbr1,桥接到eno1网卡(不同的机器物理网卡名称也不同,请确认自己的网卡名称),同时填上Proxmox本身的IP配置,以后就使用该IP地址进行Proxmox的管理。

08.jpg

同样的方法再创建一张桥接网卡,名称为vmbr2,对应eno2,不设置IP信息。

09.jpg

完成后如下图。

10.jpg

接着咱们再上传下相应的LXC镜像及ISO镜像,LXC镜像建议直接在http://download.proxmox.com/images/system/提前下载好,然后通过Proxmox的后台管理界面或者SFTP等上传上去,若直接从官网拉取,速度实在有够慢,国外服务器则忽略。

11.jpg

OK,到这一步,Proxmox的安装已经完成了,剩下的比如修改下时区什么的,就自己配置下了,完成后咱们重启下系统,让配置生效(主要是网卡配置)。

爱快安装

到爱快的官网下载最新版的ISO安装包,这里建议下载32位版,因为64位版要求2G内存,咱们没必要,官网下载地址:https://www.ikuai8.com/firmware.html,下载完成后上传到Proxmox。

在Proxmox中点击右上角的“创建虚拟机”,这是创建KVM架构的虚拟机。

12.jpg

名称随便设置一个,只要自己记得住,不可以是中文。

13.jpg

镜像就选择上传的爱快ISO镜像文件。

14.jpg

硬盘随便给点,这里康康给了2G。

15.jpg

CPU康康给了2核。

16.jpg

软路由对于内存的要求并不高,所以康康只给了512MB就够了。

17.jpg

网络这里请注意,选择刚才创建的桥接网卡,模型选择VirtIO(半虚拟化)。

18.jpg

创建完成后别忙着开机,咱们在硬件中将另一块网卡也添加进去,同样选择VirtIO(半虚拟化)。

19.jpg

20.jpg

然后修改下显卡模式为“兼容VMWare”,否则在管理控制台无法显示图形。

21.jpg

现在启动虚拟机,并打开控制台。

22.jpg

选择1,将系统装到硬盘中。

23.jpg

等待几分钟,安装完成后就出现这样一个界面。

24.jpg

直接敲回车进入管理界面。

25.jpg

咱们先给LAN口设置一个IP地址,输入2并回车,然后输入爱快的IP地址,这里康康设置的是192.168.1.4。

26.jpg

绑定完成后,就可以使用http://192.168.1.4打开Web管理界面了。

27.jpg

不过目前还不忙,咱们要绑定下WAN口的网卡,输入1并回车,在出现的界面中可以看到当前已经绑定了LAN口网卡,但WAN口网卡还没有绑定,直接输入:set wan1 eth1,请注意,这里的eth1请对应自己系统的名称。

28.jpg

绑定WAN网口后,咱们打开Web管理。

29.jpg

在“网络设置” —— “内外网设置”中,选择wan1,并配置拨号信息。

30.jpg

拨号成功后,将本机IP网关及DNS修改为爱快的IP地址,然后试试是否可以访问外网了,能够访问则表示主路由配置成功。

31.jpg

LEDE安装

主路由配置成功后,若无其他需求,其实也够了,不过康康还有其他需求,比如广告过滤,比如无痛穿墙等,所以再安装一个LEDE座位二级路由。

与爱快一样,创建一个KVM架构虚拟机,镜像选择不使用任何介质。

32.jpg

硬盘随意设置,待会儿要删除的。

33.jpg

CPU、内存、网络均与爱快一样,不过LEDE的网卡只需要给LAN的就行,也就是vmbr1

34.jpg

完成后咱们把硬盘进行分离并删除。

35.jpg

36.jpg

然后咱们下载LEDE的KoolShare修改版,地址:http://firmware.koolshare.cn/LEDE_X64_fw867/%E8%99%9A%E6%8B%9F%E6%9C%BA%E8%BD%AC%E7%9B%98%E6%88%96PE%E4%B8%8B%E5%86%99%E7%9B%98%E4%B8%93%E7%94%A8/openwrt-koolshare-mod-v2.22-r8838-af7317c5b6-x86-64-combined-squashfs.img.gz

再下载一个img转kvm的小工具:img2kvm,下载地址:http://dl.everun.top/softwares/utilities/img2kvm/img2kvm

将LEDE压缩包解压,得到一个.img文件,重命名为lede.img,与img2kvm一同上传到Proxmox上,比如上传到/root目录下,使用任意工具登录Proxmox的SSH,并执行以下命令:

cd /root
chmod +x img2kvm
./img2kvm lede.img 101 vm-101-disk-0 local

命令中,101表示LEDE的虚拟机编号,在创建时就可以看到,也可以在左侧虚拟机列表看到,而local则是节点名称,就是选择镜像文件时的节点名称,在左侧可以看到。

37.jpg

命令执行完成后,在刚才创建的LEDE虚拟机的硬件界面中,会出现一个新的未使用的硬盘文件,咱们双击打开,并添加进去就可以了。

38.jpg

39.jpg

接着在“选项”中,检查虚拟机的引导顺序是否为刚才添加的硬盘为第一引导。

40.jpg

配置完成后,就可以直接开启小鸡了,这个画面会持续一段时间,自己感觉下,或看下数字,差不多到个80多,直接按下回车就直接进入控制台。

41.jpg

在控制台中对/etc/config/network文件进行配置,也就是配置LEDE的网络,设定固定IP为192.168.1.254,今后的所有设备都通过此IP进行网络访问,同时设定LEDE的网关为爱快IP。

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth0'
    option proto 'static'
    option ipaddr '192.168.1.254'
    option netmask '255.255.255.0'
    option gateway '192.168.1.4'
    option dns '114.114.114.114'
    option ip6assign '60'

完成后重启网络。

/etc/init.d/network restart

OK,使用http://192.168.1.254就可以打开LEDE的管理界面了!

剩下的广告过滤、无痛穿墙什么的,就请研究下LEDE下的插件什么的了。

若需要所有设备均通过LEDE来达到广告过滤及无痛穿墙,可以在爱快中配置DHCP,DHCP段的默认网关设置为192.168.1.254即可。

黑群辉安装

看过康康之前文章的朋友,应该知道,康康之前是使用FreeBSD自己配置Smba、FTP、Emby等达到家庭NAS服务的。

虽然使用起来还行,但在功能上是在与专业的NAS系统存在着差距,且管理也不太方便,基于此,康康决定还是更换为专业的NAS系统算了,而在NAS系统中,群辉应该属于非常优秀的一类了,故此,康康选择在Proxmox中安装黑群辉来搭建NAS。

安装之前,咱们需要准备几个相应的文件:

  1. DS3617xs_DSM6.1_Broadwell.img:https://pan.baidu.com/s/1jIkYKke,密码: jj5s
  2. DSM_DS3617xs_15047.pat:https://archive.synology.com/download/DSM/release/6.1/15047/DSM_DS3617xs_15047.pat

将以上两个文件下载到本地,然后回到Proxmox中创建一台KVM虚拟机,“不使用任何介质”,硬盘为“SATA”格式,并分配足够大的空间。

42.jpg

CPU和内存看自己的实际情况,分配的多一定运行效率肯定更高,网卡选择VirtIO(半虚拟化),选择E1000也可以,但据说稳定性不好。

43.jpg

创建完成后不要开机,将DS3617xs_DSM6.1_Broadwell.img上传到Proxmox母鸡中,依然是刚才的/root下,然后登陆SSH执行(主要修改为自己虚拟机的VM ID及节点名称):

./img2kvm DS3617xs_DSM6.1_Broadwell.img 102 vm-102-disk-1 local

转换完成后将硬盘添加进去(图中的两张网卡是因为康康对VirtIO和E1000进行测试所用,实际仅VirtIO网卡)。

44.jpg

依然别忙着开机,到“选项”中,把引导顺序修改下,将刚才添加的磁盘1修改为第一引导。

45.jpg

看到这个界面,就用浏览器打开http://find.synology.com,这是会自动查找局域网中的群辉服务器,找到后输入IP地址开始安装。

群辉的安装网上很多教程,康康就不多说了,只要选择手动,然后导入DSM_DS3617xs_15047.pat,由系统自动安装即可,安装完成后配置为静态IP,网关设置为192.168.1.254,同时更新的时候注意只更新重要更新,且千万不要手贱升级到6.2,那就没什么问题了。

总结

这次组网是康康第一次接触软路由,也是第一次对家庭网络进行组网,以前都是通过路由器拨号,所有设备连接到路由器上即可。

由于康康对组网方面的知识也没研究过,所以也不清楚这次的组网是否合理,也不知道配置的有没有问题,但在实际使用过程中,目前来说还没什么大问题,唯一的一点就是黑群辉的网络速度,使用PC传输的话,最高只能到70M左右,使用虚拟机传输,最高只能到100M左右,也不知道是什么原因。

最后修改:2019 年 04 月 27 日 10 : 15 PM
如果觉得我的文章对你有用,请随意赞赏

发表评论

20 条评论

  1. qq

    PC传输关闭防火墙速度会到100m

    1. 康康
      @qq

      关闭防火墙?什么的防火墙?群辉的还是什么?我在WIN下就不行,现在换了Linux,速度在100M左右

      1. qq
        @康康

        windows下关闭windows的防火墙。

        1. 康康
          @qq

          已经关闭的

  2. 芋艿

    安装完爱快后,怎么通过爱快的LAN口访问PROX VE 的控制台呢?

    1. 康康
      @芋艿

      通过LAN访问Proxmox的话,直接是同一网段,没什么需要注意的啊,直接访问就行了呗

  3. jc

    康康我问个问题,我是直接在SATA5安装的proxmox,按照您的教程软路由什么的都弄好了,挺好用的。
    然后想装个群晖就算折腾完了。但是我想把SATA1-SATA4直通给群晖,这时候问题出现了。SATA1-SATA4插上硬盘后proxmox不能启动了,网上查资料说是AHCI模式下gen8不能直接启动SATA5上的系统,需要一个u盘或者SD卡来制作引导盘,但网上的都是windows的资料我尝试制作后还是不能引导proxmox,请问您有什么好的方法来实现引导SATA5上的proxmox吗?如果看到了有什么办法请不吝赐教。 谢谢!

    1. 康康
      @jc

      额,我是在淘宝上买了个gen8的改造插板,可解决STAT5启动问题的,你可以在淘宝上搜索下:“Gen8 SAS1外置系统启动Diy MiniSAS转4Sata”

      1. jc
        @康康

        首先感谢回答
        这个也行,但是感觉有点贵。我有搜索到文章【HP ProLiant MicroServer Gen8使用Super GRUB2 Disk从TF卡启动光驱位安装的Debian 8.3 https://www.mobibrw.com/2016/4172】但是我没有这方面的知识只是瞎玩,按照这篇文章操作还是不行,您能帮忙看看吗?

        1. 康康
          @jc

          这个我就不清楚了,我一直都是用那个改造插板的,没试过SD卡和TF卡,所以不直到啊

          1. jc
            @康康

            已解决,再次感谢回复

            1. Nicky
              @jc

              您好,请问您是怎么解决这个SATA5引导的问题的,能告诉我吗?谢谢

              1. 康康
                @Nicky

                我是在淘宝上买了一个扩展板,然后使用那个来接的

                1. Nicky
                  @康康

                  谢谢。请问有购买链接么?大概多少钱?

                  1. 康康
                    @Nicky

                    某宝搜索:Gen8 SAS1外置系统启动Diy MiniSAS转4Sata,100多

                    1. Nicky
                      @康康

                      好的,谢谢

  4. whatangel

    在此提供一个梗!
    低版本的pve 用img2kvm导入镜像会出现
    qm impordisk 命令错误的情况
    我按照你的教程更新的版本后就没问题了!
    终于把群晖装好了 非常感谢!

    1. 康康
      @whatangel

      额,这个真不清楚,我用的都是最新版本

  5. whatangel

    大兄弟 写的真棒!

    1. 康康
      @whatangel

      谢谢